Mercs no longer installing

Issues with mercs? Post it up here!
Forum rules
Please provide the following when making a support request.
1. OS & Service Pack.
2. Version of Mercenaries that is being used.
3. If you are using 95 Mercs, please provide what method you are using to run it? (ie. Kontza's or Slugs Hook)
4a. If you are using DOS have you read the install guide?
4b. If you are using 95 have you watched the 95 install video?
5. What were the steps that you did after the initial installation? (if applicable)
Post Reply
Aiden Pryde
I.S. Mech Washer
Posts: 20
Joined: Wed Dec 17, 2008 5:37 pm

Mercs no longer installing

Post by Aiden Pryde »

Hey all. Back again. Something new this time. I've been trying to reinstall vanilla mercs 95 using the same method that worked for me before from MMPD's video, but now the installation freezes and dies during the instalsheild stage. After it does so my only recourse is to restart the computer, because somewhere in the background the installation program stays running, consuming 100% of the CPU and making everything ungodly slow, even though the disk doesn't spin and nothing appears to be happening. I recently installed one of the brand new ATI 4800 series video cards and increased my RAM to three gigabytes, so I think it may have something to do with one or both of those I guess. But I uninstalled it AFTER I put the video card in. It still worked then, just the missions took a long time to load, just as they always did (and which I assumed was because I was operating in 3d mode). I uninstalled the game because I wanted to patch it to it's normal graphics in the hope the missions wouldn't take two whole minutes to load. Mechwarrior2 is still running fine by the way, but I'm expecting GBL in the mail soon and I REALLY hope I can get it to work.

User avatar
Skyfaller
Clan 1st MechWarrior
Clan 1st MechWarrior
Posts: 1007
Joined: Sat Apr 12, 2008 2:58 am
Location: Germany
Contact:

Re: Mercs no longer installing

Post by Skyfaller »

I would point to using MechVM, but I've messed something up with the Mercs-Win installer.
Can you use this method in the meantime?

Aiden Pryde
I.S. Mech Washer
Posts: 20
Joined: Wed Dec 17, 2008 5:37 pm

Re: Mercs no longer installing

Post by Aiden Pryde »

I really don't wanna'. I don't like DOS.

User avatar
Skyfaller
Clan 1st MechWarrior
Clan 1st MechWarrior
Posts: 1007
Joined: Sat Apr 12, 2008 2:58 am
Location: Germany
Contact:

Re: Mercs no longer installing

Post by Skyfaller »

Please don't tell me a big Clan MechWarrior, carrying a Jade Falcon bloodname and identifying with a brave and important figure in BT history, will shy away from DOS ;)

Anyway, I'll see what I can do about the Mercs-win installer, when I find the time.

Aiden Pryde
I.S. Mech Washer
Posts: 20
Joined: Wed Dec 17, 2008 5:37 pm

Re: Mercs no longer installing

Post by Aiden Pryde »

I was raised on windows. DOS is dead.

User avatar
Skyfaller
Clan 1st MechWarrior
Clan 1st MechWarrior
Posts: 1007
Joined: Sat Apr 12, 2008 2:58 am
Location: Germany
Contact:

Re: Mercs no longer installing

Post by Skyfaller »

Sorry, can't help you. Can't get the Win95 version to work myself on either Win XP SP3 nor Vista SP1.

User avatar
Sir MMPD Radick
Clan Nova Captain
Clan Nova Captain
Posts: 1617
Joined: Tue Jan 22, 2008 10:07 am

Re: Mercs no longer installing

Post by Sir MMPD Radick »

I have to echo what skyfaller said.. use the DOS version.. The 95 versions are unstable.
95 versions will install and work for a while but mysteriously stop seemingly randomly.
The only solution for mercs versions that work one minute then stop the next is a format which may or may not work... bottom line it is not worth the trouble.

As for seemingly running background installs.. no idea how to fix that other than grabbing every necessary file off the disc and running it without the installer.
If you must have a 95 version I can provide a file list which you can use to get all the necessary files off the disc without the installer.
James 3:5-10: My Reminder
And the tongue is a fire, a world of iniquity: so is the tongue among our members, that it defileth the whole body. Out of the same mouth proceedeth blessing and cursing. My brethren, these things ought not so to be.

Aiden Pryde
I.S. Mech Washer
Posts: 20
Joined: Wed Dec 17, 2008 5:37 pm

Re: Mercs no longer installing

Post by Aiden Pryde »

That sounds like... a different kind of installer.

I tried it on DOS before but I still had it installed through windows that time. The quality was really terrible.

User avatar
Skyfaller
Clan 1st MechWarrior
Clan 1st MechWarrior
Posts: 1007
Joined: Sat Apr 12, 2008 2:58 am
Location: Germany
Contact:

Re: Mercs no longer installing

Post by Skyfaller »

IIRC, MechVM's Mercs installer creates a hybrid DOS/Win install. It lacks the patches necessary to run the Win version, but perhaps you can get it to work with Köntzä's patch or the hook. My problem is that I really can't get the Win version to work, even when patching an install from the official installer.

One more thing: the DOS version should be quite unaware of any Windows installs. I'd bet you have to run another installer, I think it's located in the DOS directory.

Post Reply