Mercenaries for Mac: Easy and Nightmare

Issues with mercs? Post it up here!
Forum rules
Please provide the following when making a support request.
1. OS & Service Pack.
2. Version of Mercenaries that is being used.
3. If you are using 95 Mercs, please provide what method you are using to run it? (ie. Kontza's or Slugs Hook)
4a. If you are using DOS have you read the install guide?
4b. If you are using 95 have you watched the 95 install video?
5. What were the steps that you did after the initial installation? (if applicable)
Post Reply
I.S. Baby
Posts: 1
Joined: Thu Nov 01, 2018 6:09 pm

Mercenaries for Mac: Easy and Nightmare

Post by Imperator »

For Mac users, getting Mechwarrior 2 Mercenaries to work can be especially problematic. I've been able to get it working one way, for the DOS version. The other way has been a nightmare for the Windows version. Why would we want the Windows version? For 1.1 dynamic salvage, of course. At any rate, here's how I got 1.06 DOS to work. The other route appears to be hopeless, but perhaps some of you can lend advice.

1) Mercenaries DOS 1.06

-Install DOSBOX and create a bin/cue file from Mercenaries (done with a few Mac equivalents of PowerISO).
-Create folder in home directory (the equivalent of the C drive); I called mine DOSMERCS. Place the bin/cue file in the folder, plus your installed MERCS folder. Then, go to the DOSBOX preferences text file and add the following after the line '# Lines in this section will be run at startup.':


-Upon clicking on the app, it will load automatically. Mine had the sound working right away without needing to calibrate. You may have a little difficulty with the highest game resolution, but it can be mitigated by playing around with other performance settings in the preferences file (be sure to set cycles=max). The game mechanics work near perfectly, aside from the usual in-game bugs and glitches. Also, I've noticed a very annoying problem where enemies spawn under elevated landscape where they can damage you, but you can't damage them until they move out of the graphics. HOWEVER...the game still works great, especially for someone dying to play. I also had no issue with keyboard settings!

2) Mercenaries Windows 1.1

-This has been an arduous route. I decided to try and install both Windows 98 and Windows XP operating systems in VirtualBox (free). If you have not done so before, there are some additional steps for Windows 98, which needs a special driver to solve the absurd sluggishness problem. Windows XP also requires something called Guest Additions, but these can be easily downloaded. You will need your OS installation CD or an ISO file that you can purchase on Ebay. Also, don't forget your product keys, which should be legally obtained, of course.

-Once my operating systems were set up, I tried three methods. Both MechVM and Slug's Hook for XP and simply installing Mercs on Windows 98. All of them ended in failure, crashing after launching missions or clicking on menu options. I should mention that I use the original Mercs DOS/Win CD, not Titanium.

-For Windows XP, used MechVM to install Mercs and pointed to the cue file. Game installed and appeared to load successfully; intro video worked and main menu appeared. However clicking any of the menu icons resulted in a voice stutter, then crashing with a fatal error saying that the CD-Rom was not mounted. There is no difference if I install Mercs first, then use MechVM, or just use MechVM to install.

-For Windows XP Slug's Hook, I first installed Mercenaries the regular way. Then, loaded SH but it said it could not find any installations. So, I created the shortcut and was sure to include the proper arguments after the file path. Game loads even better; intro video was good and I could successfully navigate the campaign rooms (terminal, contract database, etc). However, launching any mission resulted in another crash with the same fatal error message saying my CD-Rom was not mounted. Instant Action does the same thing.

-For Windows 98, I really thought this would work. But, once again, clicking any menu option results in Task Manager saying it has encountered a problem and needs to close. Incidentally, my OS stopped booting successfully in VirtualBox after this occurred. Immensely frustrating.

In conclusion, Slug's Hook seemed to deliver the best result, but the fatal error seems impossible to solve. I don't see how it could possibly fail to detect the disk when it was used to install and appears in the D drive when going into My Computer. I should also mention I did all of this BEFORE trying to patch to 1.1 and then patched first just to see if it changed. Nothing works.

So, Mac users will find that DOS 1.06 can work just fine. I've already played two campaigns with little headache (aside from the enemy no-damage bug, but this only gave me some trouble on the first Gravenhague mission and the last two missions on Luthien). However, for those who want dynamic salvage (I still certainly do), the Windows version is maddening to get working. There may be no solution in sight aside from running Windows 98 on a real, compatible machine...but who has the resources or space for that??

Any help with the Windows route would be appreciated; I've pretty much given up hope solving it myself at this point.

EDIT: Screenshot of the issue attached.
Screen Shot 2018-11-08 at 12.59.36 PM.png
Screen Shot 2018-11-08 at 12.59.36 PM.png (20.05 KiB) Viewed 2265 times

I.S. Mech Washer
Posts: 16
Joined: Mon Mar 11, 2019 9:41 pm

Re: Mercenaries for Mac: Easy and Nightmare

Post by slickrcbd »

Funny, every time I look at this topic I think I missed a Mac version back in the day. AFAIK only the first MW2 game was released for Mac, the one that was bundled with my PowerMac 6500/300 and introduced me to 'mechs and Battletech.
I kept waiting for GBL or 'mercs to come out, but it never did.

Post Reply