Mercs 95 1.1 texture problem

Issues with mercs? Post it up here!
Forum rules
Please provide the following when making a support request.
1. OS & Service Pack.
2. Version of Mercenaries that is being used.
3. If you are using 95 Mercs, please provide what method you are using to run it? (ie. Kontza's or Slugs Hook)
4a. If you are using DOS have you read the install guide?
4b. If you are using 95 have you watched the 95 install video?
5. What were the steps that you did after the initial installation? (if applicable)
Post Reply
peril
I.S. Baby
Posts: 2
Joined: Wed Dec 21, 2016 12:32 am

Mercs 95 1.1 texture problem

Post by peril » Wed Dec 21, 2016 10:56 pm

Hey there,

I hope people out there are still active! I have an irksome problem with Mercs 95 and patch 1.1

Windows XP SP3/Windows 95 VM/Windows 7
Mercs 95
MechVM/Slug's Hook/Köntzä's patch all have same error

Basically, when I patch the game, the game decides not to display textures past ~1000metres. Using farpatcher to boost draw distance doesn't help. Buildings are just blocks that textures pop onto as you get close, and there is this grey area toward the horizon that marks the untextured boundary.

From what I can tell this is a very old bug that cropped up eons ago.

I tried on two different machines, with three different OSes and three separate graphics solutions (one was Intel integrated graphics, two were disparate AMD cards).

I must assume this is due to a quirk during patching. I experimented with swapping out mercsw.dll from a pre-patch install and this fixed the graphical issue (but rendered the game too unstable to play).

This leads me to believe there is a value in there somewhere that could be adjusted to remedy the issue, but popping it open in a hex editor shows there's a lot to search through and I don't have a clue what I'm looking for.

Ideas?

User avatar
Havokq3
House Steiner Corporal
House Steiner Corporal
Posts: 91
Joined: Sun Sep 06, 2015 6:27 pm
Location: 31st Century Kansas

Re: Mercs 95 1.1 texture problem

Post by Havokq3 » Thu Dec 22, 2016 6:13 pm

Well, I would assume that the 95 version was not meant to display detailed textures from over 1km away. Considering the processing power of PCs at the time, I'm guessing the developers didn't think you would to need look so close at something so far away. Other than that, I can't think of another good reason why.
The year is 2015. For a Mail Officer, LIFE is WAR, and DEATH is the only true peace.

peril
I.S. Baby
Posts: 2
Joined: Wed Dec 21, 2016 12:32 am

Re: Mercs 95 1.1 texture problem

Post by peril » Sun Dec 25, 2016 7:25 pm

Yeah, I considered that, so I tested a clean install (patched to 1.1) on Windows 95, and the issue persists. I also tried pulling back the draw distance watch farpatcher but the problem with lack of textures toward the horizon (just shows grey) remains.

As I mentioned, when adding back the pre-patch mercsw.dll the graphical issues are not present, but it's too unstable to play for more than a couple minutes.

I also found a newsgroup post from when the patch first came out ~20 years ago and folks were reporting the same issue.

By the looks of things it may just be a simple variable in the mercsw.dll that needs a tweak, the only problem is which one! :(

Post Reply