Mercenaries DOS Framerate Issues

Issues with mercs? Post it up here!
Forum rules
Please provide the following when making a support request.
1. OS & Service Pack.
2. Version of Mercenaries that is being used.
3. If you are using 95 Mercs, please provide what method you are using to run it? (ie. Kontza's or Slugs Hook)
4a. If you are using DOS have you read the install guide?
4b. If you are using 95 have you watched the 95 install video?
5. What were the steps that you did after the initial installation? (if applicable)
Post Reply
User avatar
MensloWolf
I.S. Baby
Posts: 13
Joined: Mon Jan 19, 2015 2:41 pm
Contact:

Mercenaries DOS Framerate Issues

Post by MensloWolf » Sat Jan 24, 2015 7:40 pm

I've been playing MW2 Mercs thru DOSbox a whole lot recently, however I am never really satisfied with the framerate. I am always getting around 15-20 fps , but i want at least around 50-60 fps. I am currently using Win 8.1. Here are my DOSBox config details (Edited to remove unnecessary text):

# This is the configuration file for DOSBox 0.74. (Please use the latest version of DOSBox)

[sdl]

fullscreen=false
fulldouble=false
fullresolution=original
windowresolution=original
output=surface
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
mapperfile=mapper-0.74.map
usescancodes=true

[dosbox]

language=
machine=vga
captures=capture
memsize=16

[render]

frameskip=0
aspect=false
scaler=normal2x

[cpu]

core=auto
cputype=auto
cycles=auto
cycleup=10
cycledown=20

[mixer]

nosound=false
rate=44100
blocksize=1024
prebuffer=20

[midi]

mpu401=intelligent
mididevice=default
midiconfig=

[sblaster]

sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=44100

[gus]

gus=false
gusrate=44100
gusbase=240
gusirq=5
gusdma=3
ultradir=C:\ULTRASND

[speaker]

pcspeaker=true
pcrate=44100
tandy=auto
tandyrate=44100
disney=true

[joystick]

joysticktype=auto
timed=true
autofire=false
swap34=false
buttonwrap=false

[serial]

serial1=dummy
serial2=dummy
serial3=disabled
serial4=disabled

[dos]

xms=true
ems=true
umb=true
keyboardlayout=auto

[ipx]

ipx=false

[autoexec]
mount c c:\games
c:
cd mechwa~1
cd mechwa~1
imgmount d c:\games\mechwa~1\mechwa~1\mercenaries_doswin.cue -t iso
cd mercs

Help please!
Image

User avatar
Sir MMPD Radick
Clan Nova Captain
Clan Nova Captain
Posts: 1614
Joined: Tue Jan 22, 2008 10:07 am

Re: Mercenaries DOS Framerate Issues

Post by Sir MMPD Radick » Sun Jan 25, 2015 1:42 pm

mercs generally runs slower than mech2 would because it requires more processing.. you might have to just use frameskip if you want to have it seem faster unfortunately there are not a whole lot of other things you can tweak.

My best suggestion would be to use Taewoon's svn version of dosbox as it usually has more speed tweaks and more options. If you do that you could try direct x or Open GL which could help with speed considerably over surface rendering.
James 3:5-10: My Reminder
And the tongue is a fire, a world of iniquity: so is the tongue among our members, that it defileth the whole body. Out of the same mouth proceedeth blessing and cursing. My brethren, these things ought not so to be.

User avatar
MensloWolf
I.S. Baby
Posts: 13
Joined: Mon Jan 19, 2015 2:41 pm
Contact:

Re: Mercenaries DOS Framerate Issues

Post by MensloWolf » Sun Jan 25, 2015 3:12 pm

Thanks for the Info Sir Radick!
Image

User avatar
Striker
House Steiner Private First Class
House Steiner Private First Class
Posts: 66
Joined: Mon Jun 09, 2014 9:55 pm
Location: Canada

Re: Mercenaries DOS Framerate Issues

Post by Striker » Mon Jan 26, 2015 3:58 pm

The thing about dosbox is that it that it tends to limit your CPU output to make older games play acceptably. I distinctly remember being able to run MW2: Mercs on my Pentium 3 700 mhz years back with silky smooth graphics... but today, for some reason, on my Windows 8.1 modern laptop, I do get the occasional framerate drop that makes me feel as though I'm playing on my Pentium I 133mhz again.

One thing you can try is pressing Control F12 a few times to see if it smooths things out, as that is supposed to increase CPU speed in doxbox I think.

Another thing you can do is edit your gamekey.map file, and add the following line:

ENHANCED_VISION w

Basically, the above is a walkaround. If your game slows down, pushing W will turn everything into wireframe kind of like the enhanced imaging feature in 31st century, and will completely smooth things out.

burningwreckage00
I.S. Baby
Posts: 4
Joined: Thu Aug 28, 2014 12:21 pm

Re: Mercenaries DOS Framerate Issues

Post by burningwreckage00 » Tue Jan 27, 2015 2:26 pm

Things that worked for me when playing mercs in dosbox a long time ago would be to lower the resolution, disable object textures, and/or disable terrain textures. Too bad dosbox doesn't have a 64bit version, since the devs said it was slower than the 32bit versions.

User avatar
Havokq3
House Steiner Corporal
House Steiner Corporal
Posts: 91
Joined: Sun Sep 06, 2015 6:27 pm
Location: 31st Century Kansas

Re: Mercenaries DOS Framerate Issues

Post by Havokq3 » Mon Oct 12, 2015 4:39 pm

In the game's configuration file, change the line

Code: Select all

core=auto
to

Code: Select all

core=dynamic
. This tells Dosbox that it is a cpu heavy program, and to allocate more processor power to it.
The year is 2015. For a Mail Officer, LIFE is WAR, and DEATH is the only true peace.

Post Reply